Simple Download Monitor problems

Started by pepak, November 04, 2009, 11:46:40 AM

Previous topic - Next topic


Nothing helps with WP super cache.
Uninstall it and install W3 Total Cache.
It works without those errors but there is an error with flv-player.
When I hit button play time indicator of flash player goes to very end as if the movie completely has downloaded
To correct it I turn off "Enable HTTP (gzip) compression"  in Browser Cache settings.
Now it works.
Thank You!


I still think it should work fine even with gzip compression and WP super cache. Please make sure you really are using SDMon version 0.18 - there were some problems between W3TC and older versions of SDMon, but they should be fixed in 0.18.


Yes, I use Simple Download Monitor  0.18.
With  wp super cache when I push play button it writes me that he could not find video 404 error.
But with http watcher i have seen that video downloads


I would love to install and use your plug-in. However, I have the DAP {Digital Access Pass} plug-in installed, which is a membership site and it is already redirecting things using the .htaccess file.  I was told by DAP that I cannot edit the .htaccess file as you need for the SD Monitor plug-in to work.  

Is there any way that you can see to track downloads from a certain folder without the need to edit the .htaccess file?  I really need  to be able to see the # of times a file is downloaded, who has downloaded it, and when.  

Please help!  Thank you very much!!


There is a way, but you would need to sacrifice the main feature of SDMon - its ability to work without modifying anything.

If you can modify .htaccess, you use URLs such as /files/youtube/ To switch to a htaccess-less SDMon, you would have to change the URLs to /index.php?sdmon=files/youtube/


I'm experimenting problem with Simple File Manager and symbolic links.

The issue is around lines 300-308 of simple-download-monitor.php when $relfilename is defined as substr of $fullfilename. That's misleading when symbolic link are involved since realpath() returns, as it's name suggests, the *real path* (ex. /home/user/file.txt) which brings the download to be marked as invalid...

To be sincere I'm experimenting  the symbolic link's problem only in my test environment, on the production website I don't expect (haven't tried yet) any kind of trouble (since no links are involved there), so it's not a big deal for me, nevertheless I'm trying to find out a viable solution since it could be usefull for others, that's also why I'm writing here now ;)


Sorry, my experience with symbolic links on the web is nonexistent and I have no server on which to test it. The code around realpath is required to prevent security issues from malformed requests (e.g. attacker trying to read wp-config.php).


The plugin does not restrict user access to members only.. it lets anyone download.  I have a potential idea for the cause.  My files are located in subdirectories of the files directory.  Do I need to add a rule for each subdirectory to .htaccess for this to work?


That is intentional, as I never had a need for limiting access. It may appear in some future version.

No, you don't need to add each subdirectory to .htaccess. The main one (files/) is sufficient.


Hello Pepak, I've tried over 100 posibility to make this plugin to work, but without any result, can you help me please. I think your plugin is very useful for me.

So, I've attached here 3 images, one with config panel from Wordpress, second with root of my host and 3rd with .htaccess file to view the lines .

I need this work in my - in this /members/ subdirectory have another wordpress installed.

Please let me know what's wrong in this case and make this workable,

Best Regards, I am looking forward to your answer.



I need this work in my in last post I missed the last "s" from members.

was a mistake in last post.

- in this /members/ subdirectory have another wordpress installed.


Quote from: ionelpaun on March 21, 2012, 01:16:06 PM
Hello Pepak, I've tried over 100 posibility to make this plugin to work, but without any result, can you help me please. I think your plugin is very useful for me.
First things first: Did you try to use a "direct SDMon link" such as What was the result?

a) Download works - then the problem lies in your .htaccess file and I am afraid I won't be able to help much as I am not very good at .htaccess.

b) Download doesn't work - then the problem lies in your SDMon configuration. I suspect the problem might be caused by the fact that you use the /members directory for your WordPress install. You may want to try to add members/ to the beginning of your "allowed directories" option. (Which reminds me, is your "allowed extensions" setting correct?)


Hello there,
When I try with this direct link,
it works, Simple Download Monitor record this download in status.

But, in config menu at the allowed directories I have "wp-content/plugins/s2member-files/" - download works

If I put in the allowed directories "members/wp-content/plugins/s2member-files/" the direct link download doesn't work, it appear with SDmon Download Error.

Do you have another suggestion ?
Thank you very much.


and at the allowed extensions I've put only "zip" for zip files.

best regards,


Since the index.php?sdmon link works, that confirms that your SDMon config is correct. The problem lies in your .htaccess file, and as I mentioned above, I am afraid I won't be able to help you with that. But I suspect that if you look at your webserver's logs, you will see the reason - probably you will see that the URL doesn't get rewritten to as it should, but to something else. If it idn't this obvious, you will need to locate someone good with .htaccess, and unfortunately that group doesn't include me :-( (but at least now you know where to look for the cause of the problem).

Quick Reply

Note: this post will not display until it has been approved by a moderator.

Please leave this box empty:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Shortcuts: ALT+S post or ALT+P preview